Admin access gone after upgrade


this problem exists now for about 2-3 months but unfortunately I had no time to check it earlier: the admin pages for my forum are gone. I can just edit content as any other logged in user but I can’t administer the wiki - like granting roles / right to other users.

Does anyone have a glue how to fix that? I think the problem came up with an upgrade where I accidetially removed or “misupgraded” some plugins.



To investigate and repair the situation you can activate the “superadmin” account.

On the file system edit the “xwiki.cfg” (location depends of the installation, but usually it should be found in the “WEB-INF” directory of the XWiki webapp). Look for a line like:
# xwiki.superadminpassword=system.
Uncomment that line and change the value “system” to something else (this is the password for the superadmin account). You need to restart XWiki to make the change effective.

Afterwards you should be able to log in as “superadmin” and the password you have choosen. Investigate the history of the “XWiki.XWikiPreferences” page, if there are any changes to the " XWiki.XWikiGlobalRights" which removed the admin right to the Admin user or the XWikiAdminGroup.
You will need to type in the URL manually as: or something like that.

Of course you can first visit the wiki administration first to fix the rights of your admin user.

When you are done, do not forget to comment the “xwiki.superadmin” in the “xwiki.cfg” and restart the server a second time to avoid leaving the superadmin account active.

Some Documentation about that feature:

Hi Clemens,

thanks for your answer back then almost a year ago. Now this thread is old, but the problem is still remaining.

What I apparently forgot to mention: this is not a local / personal XWiki installation but it’s running under To be more precisely:

Best regards,


I just performed a quick check: the Admin link displayed in the drawer is coming from the following XWiki Page: AdminUIX - XWiki
I’m not sure why but apparently its current status was prevent the administration link to be displayed: in general it means that the page have been saved with a user not having the proper rights, but apparently here the user is you so it seems a bit odd.
Anyway, I rolled back the page to the version from latest upgrade and apparently it’s been enough to have the link appearing back.

Hope that helps!


sorry, I don’t think that that worked.
I can see the AdminUIX page now, yes. But I am still not able to administer the wiki.

I think, I removed some rights / roles from my profile or from a profile which we used to administrate …

sorry to push that topic again. But I still can’t see / access anything that really let’s administer the wiki.

Hi, I tried to live with redirects with $response.sendRedirect() but even with that I have now problems. A redirect which used to work doesn’t work now. I do not know, when it was broken.

Is there any chance that someone can give me admin access to my project mentioned above?
Because now I am totally stuck … no redirect, no deletion of pages and for a long page no administration of my myxwiki space. …

@Doumanix Hi. Could you give me a URL that I can check?

Example of not working redirect:äte/Sensoren/Rauchmelder_ARM/

Previously worked this but now it does not anymore:


hmm It leads me to :wink:

I’ve noticed that you haven’t upgraded your wiki, maybe you should start by doing so:

We’ve added a check for untrusted domains relatively recently and is not in the list of trusted domains. That’s why you didn’t see it before.

You should check

I recommend using the XObject way.

I’m going to document it at

But this is my main issue why I opened this thread a long time ago: I CAN’T!!

I do not have admin access to my wiki. Without that I don’t have the right to upgrade

Here is my initial post which decribes the problem, which remains until today:

hmm just realized that you want to redirect to some outside website and not to So both solution will not work without adding the site to the allowed domain list.


Ok, got it.
But that leads me one more time to the point: how do I get back my admin access?
I wrecked it 1,5 years ago and nobody could help so far …

I’m checking it.

So it should now work and you should be able to access your wiki (seems there were some apache rules causing some problems).

Hi Vincent, unfortunately, it didn’t help.
I still do not see a link in the menu leading to the administration.

I played a bit and saw this hint
This page and its children contain internal content used by XWiki for its own use. It also currently contains the User Profile pages. You can administer your wiki through the [Administration application].
when I accessed it via /xwiki/bin/view/XWiki/

But when opening /xwiki/bin/view/XWiki/XWikiPreferences … I get this error: You are not allowed to view this page or perform this action.