Fail to edit in WYSIWYG


I have a problem, when ever I want to edit a macro on Xwiki WYSIWYG editor, this error occurs!

“Failed to retrieve the children/xwiki/2.1 macro descriptor.”

Anyone have any clue where to solve this?


… does the error expand if you click it (the read text)?

no, there is nothing when I clicked any button or the text.

Any help I would be very appreciated. Maybe just a clue where should I debug is also good.
I tried to update uninstall the unsupported macro, it wont work too.

What browser do you use? Did you try with another browser and private mode?

If there is no additional information on this in the error itself, it is probably not server side, you might try to debug with the browsers web developers tools (aka Console) to see if the page produces any error in the browser while the above condition exists. Just an idea…

I use Chrome.
Xwiki v13.9. I tried to switch browser/ clear cache etc already from times to times.

I found some errors in Console. sorry I am not familiar with web dev. Any idea?

And also sometimes appear warning related to macro:
DevTools failed to load source map: Could not parse content for https://…de:443/bin/jsx/Menu/MenuMacro?sourceMap=true&minify=false&language=en&docVersion=1.1: Unexpected end of JSON input

I’m not an expert either and not using Chrome, but more or less all the browser start to be the same anyway … However, both errors are not optimal … what is shown in the Console tab (the console tab at the top area of your screenshot).

Not sure if this helps, what is returned if you load “https://…de:443/bin/jsx/Menu/MenuMacro?sourceMap=true&minify=false&language=en&docVersion=1.1” in your browser in an empty tab?

Do you use any Antivirus that integrated with your browsing? Did you try from another computer? Do all users have the same issue?


I don’t have antivirus. I tried to load the page and only white page comes out. All user have the same issues, we are just a small team but have the same problem on all computers. So I suggest the problem is not from the Browsers.

Sorry missed that, I have the same errors in my console and not the same problem you have … so this is not the cause I think.

I assume your wiki is in German, right. I have a sub-wiki in German too, Version 13.9, and don’t have the same issue you have. Sure, there might be many differences between your and my setup …

Another idea: Do you use a reverse proxy or similar? Did you try to access your servlet container directly (like IP:8080 or IP:8443 or whatever port it is listening?)

I think I have the same issue as in:

I had the same issue with the list of available macros.

I tried to reinstall CKEditor Integration, after the uninstallation, when ever I search the extension, this error shown:

Maybe this could be a clue?

Many thanks

I solved the problem by restarting the docker container of xwiki, reinstall the CKEditor Integration.
Thanks for you help!!