Initial Save returns Failed to save the page. Reason: Server not responding

Hello
We have a reproducible problem saving new documents.

Note that there is no problem creating a new document from the ‘Blank Page’ template.

However, if a new document is created using one of the templates (e.g. Meeting Report or Simple Page) then on Save&View we get the error

Failed to save the page. Reason: Server not responding

But the document is saved on the 2nd attempt to Save&View.

The above error also occurred when adding an emoji and this problem was corrected by changing the MySql charset to utf8mb4 after following the advice on several posts (such as https://forum.xwiki.org/t/wysiwyg-editor-one-page-one-sentence-if-add-smily-face-wont-save/7440)

Has anyone else seen this issue? If so is there a fix?

We have XWiki version 12.9-1
mysql --version
mysql Ver 14.14 Distrib 5.7.24, for Linux (x86_64) using EditLine wrapper

The XWiki and MySql images are running in Openshift containers with non-root access.

Thanks in advance for any feedback
Pete

Hi,

Can you check the browser javascript console when the problem occured to see if there’s any error? Can you also check the browser network tab, you should see a request to a path containing /save/ probably with some 500 status: it would help to have the actual content of this answer.
Finally you could check the xwiki server logs when it happens it might display the root cause of the error.

Hello
Thanks for the reply

I created a new ‘Simple Page’ .
On the 1st save I had the error (as above). In the Firefox Web Developer console

Warning: The script from “https://…/bin/get/CKEditor/Config?outputSyntax=plain&t=K9DA” was loaded even though its MIME type (“text/plain”) is not a valid JavaScript MIME type. WebHome
Error: Blocked loading mixed active content “http://…/rest/jobstatus/refactoring/create/1605709180678-429?media=json” prototype.js:1745:21

And the Network Tab shows an error xhr ‘Mixed Block’ on the last line. There is no /save/ in the Network Tab

When I click a 2nd time the document is saved and the above errors do not appear.
There is nothing obvious in the /usr/local/tomcat/logs

Pete

Sounds like a bad handling of https on your server.
Apparently you access it on https but the request are made with http.

Now maybe it’s just a browser cache issue: can you check after cleaning your browser cache?

Can you check by using “save & continue” instead of “save & view”, open the network tab before clicking the button.

I cleared the cache and restarted Firefox.
With the Network Tab open I create a new Simple Page. On Save&Continue the error message Failed to save the page. Reason: Server not responding appears and one line is added to the Network Tab showing the error error xhr ‘Mixed Block’ .

Similarly on the chrome browser and I get the same result. The Network Tab shows
Status = blocked:mixed-content
Type = xhr
Initiator = prototype.js:1745

Not 100% sure any more, but I believe to remember to experience a similar issue when using a macro to trigger the page creation from a template. I have set

xwiki.cfg:xwiki.url.protocol=https

in my config, which might have mitigated this (or I changed the way the template was used … )

Does not hurt to try I guess …

Hi
Thanks for the feedback.
I made the change to xwiki,cfg but unfortunately the problem is till there.

There is a case here http://jira.xwiki.org/browse/XWIKI-13963 where the setting is ignored when set.
Perhaps these are related

Okey, then it was maybe this setting:

xwiki.cfg:xwiki.home=https://host.yourdomain.tld/

HTH

Hello
I added the setting to the xwiki.cfg but I still get the same error.

In the logs I see a difference when creating a ’ Blank Page’ and a ‘Simple Page’

When saving a ‘Simple Page’, the log shows an extra line

10.76.27.1 - - [23/Nov/2020:09:20:34 +0000] “GET /rest/jobstatus/refactoring/create/1606123234118-136?media=json HTTP/1.1” 200 423

This line does not appear when saving a ’ Blank Page’ which works fine and as expected.

Only to make sure: you restarted your Java container, right?
The request is status 200, but as @surli mentioned, your browser will potentially block this. So my memory failed me and I did something else to circumvent this… but I don’t remember what … I’ll try to find it…