My activity history - "Unknown macro: notifications."

Hi everyone,

i have been struggling with the error message since a new installation, for example when i change to my xwiki profile only the error message “Unknown macro: notifications.” is displayed under the subheading “My activity history”

Maybe someone here can help me

Many thanks in advance

Using XWiki 11.10.2

Hi, it could mean that you’ve done some weird stuff in your wiki during upgrades :wink: as it probably means that you’re missing some notification extension (which is an extension you have by default in XWiki).

Specifically org.xwiki.platform:xwiki-platform-notifications-macro-ui also known as Notifications Macro. You should verify that you have it in the list of installed extensions in your wiki.

Maybe you could also provide a history of what you did.


Many thanks for your quick feedback

Unfortunately the macro has not worked correctly since the beginning

Is it possible to reinstall this macro or fix the error?

We want to use the macro in wiki and subwikis


I see in your screenshot that you installed the macro. Any error in the logs on the screen (checking using the vertical scroll bar visible in the screenshot)?

Is the macro working now that you’ve installed it?

Did you install it at the level of the farm or just the current wiki?


It was already installed and without error messages in the installation log/process history

It is installed on the top level and in the lower levels as a dependency

Also checked the page “https://mywiki/bin/view/XWiki/Notifications/Code/Macro/NotificationsMacro” but it’s not available on this site

It also is “{{notifications/}}” and add gadget “$services.localization.render(‘’)” not working

ok so it means someone has deleted this page probably.

You need to reinstall the extension then.

I have now uninstalled and reinstalled the extension

Unfortunately without success

After the reinstallation I can no longer access the administrator area, the user directory and the subwiki pages/contents

Is there a way to reset the last step for the complete wiki?
I am missing countless pages and contents here now…

I think you may have uninstalled not only this extension but also all the other ones that it depended on which is why you’re missing lots of things.

Actually there was a better solution which was to reset the extension, sorry for not mentioning it:

Right now I think you may need to uninstall/reinstall the XS flavor itself. Now if you can’t access the admin that’s going to be hard. You cannot even import a XAR in the admin?

@tmortagne any other idea?

I still have the advanced mode for advanced users active, but can access the administration area etc. more and also (and not import xar-files)

I have removed the dependencies during uninstallation and only uninstalled the extension “Notifications Macro”

Can you access the https://mywiki/xwiki/bin/view/XWiki/Extensions page ? (In other words was ExtensionManager uninstalled).

If you don’t have Extension Manager and since you apparently uninstalled the flavor (which was explicitly indicated when you uninstalled the extension) you could reset the distribution status to let XWiki propose you to install the flavor when you restart, you can do that by removing the file <xwiki permdir>/jobs/status/distribution/status.xml.

I still have access to the extensions https://mywiki/bin/view/XWiki/Extensions but I have lost my administrative privileges and a subwiki cannot be created/reset

How can I regain administrator rights without an active administrator?

Is it possible to reset the changes of the extensions to the state before the uninstall/update without modified/loosing the contents (pages, attachments) of the wiki

@xdocu the simplest is probably to do what Thomas suggested:

Have you tried this?


I got my administrator privileges back and also the access to the extension manager as well with XWiki Standard Flavor and Notifications Macro

Even after uninstalling and installing Notifications Macro it still does not work

In the Dashboard, where we added the Gadget


And alos as well in the User Profil


Do you have an idea how we can solve this problem?

I have already thought about to upgrade our wiki to the new XWiki version “12.7.1”