Navigation panel doesn't load

I’ve got an issue with my xwiki site, it began when a user/admin tried to move the XWiki namespace to another namespace. This broke the wiki badly, but after moving the XWiki namespace back, reinstalling the Menu application and restoring some group permission the wiki almost work again, except for the Navigation panel, when loading a regular page it never stops spinning saying “Loading” see screen below:
xwiki-loading
Now, if I open the javascript console in Chome I get this error message twice when opening a page on the wiki:

Uncaught TypeError: Cannot use ‘in’ operator to search for ‘length’ in #updateDocTreeConfigFromRequest
#handleDocumentTreeRequest
at s (jquery.js:535)
at Function.each (jquery.js:362)
at h (tree.min.js:1)
at Object.L (tree.min.js:1)
at i (jquery.js:3187)
at Object.fireWith [as resolveWith] (jquery.js:3317)
at z (jquery.js:8785)
at XMLHttpRequest. (jquery.js:9151)

Can you please help me debug/fix this? This is my first experience with xwiki and it didn’t start well.

More information:

  • When going to the Administer Wiki page the navigation menu loads fine, or when opening the XWiki namespace or a page under the XWiki namespace
  • I’ve created a new subwiki with the Wiki application and that works good, but I cannot find a way to replace the main wiki with the new subwiki
1 Like

Bump, please help me.

Have you tried rolling back the Wiki to its previous versions before the namespace change?

@arune Were you able to resolve this issue? I got the same issue for unregistered user.
It works perfect for registered users.
How did you resolve?