I would like to add a new boolean property to the page information both in view and edit mode (where it is a panel) to enable/disable heading numbering for numbered headings in the new numbered content contrib extension. This needs a new UIXP.
At the moment, we have two views of page information:
- In informationinline.vm for view mode and inline editing.
- In DocumentInformation.xml for WYSIWYG and wiki editor
They display similar content, though the latter displays less and uses different HTML as the data is saved together with the content and this is also for new pages. We could try to unify these views as some differences seem strange (e.g., having a yes/no-select vs. a checkbox for the hidden property) but this might be a lot of effort and I’m not sure it is possible. Therefore, I think the best would be to have two new UIXPs so it is easy to target just one or the other view and to display different content for both of them.
Both use definition lists for display, so I think it makes most sense to make each item a UIX.
Concerning the UIXPs:
- Should each UIX just contribute a part of the HTML code that is inside the definition list or should there, e.g., be a parameter for the content of the
dtsuch that the actual content is just the content of the
informationinline.vm, we need the possibility to set attributes of both the
ddelement so this would mean that we need a lot of parameters. Or is there a better solution?
- Should the existing content be moved to new UIXs (or one, if we go for the "just a part of the HTML code)?
- I suggest to add a column=left/right parameter to target the respective columns in the
informationinline.vmtemplate and a priority for ordering.
org.xwiki.platform.panels.ui.documentInformation(named according my understanding of the naming convention) for the panel - or remove the “.ui” part?
org.xwiki.platform.web.templates.informationfor the information tab?
- The existing
org.xwiki.plaftorm.template.docextrahas “template” in singular and no “web” - should we do the same? Note: we should probably not adopt the spelling error of
plaftormeven though this would be more consistent.
- The existing