Office 365 Login using Open ID Connect

Hi Users,

I have performed office 365 login using OpenID connect. I have followed the configuration steps, and i can able to get the login page, after providing right credentials, it displayed following error.


Can anyone help me out? please…

Can’t really say much from that screenshot, would need the complete error (especially the last “caused by”).

Hi tmortagne,

Here it is, the complete one

You will need to look at the application server log to get the full one as indicated in the screenshot actually.

Actually Its the same one which I got in server log too…

Well this is definitely not complete, you are missing at least one “caused by” level. Are you really sure you don’t have more in the application server log ?

@tmortagne Do I miss any?!? could you please help me out???


Attached server log file.

localhost.2017-10-30.log (165.4 KB)


I think problem is here,

org.xwiki.contrib.oidc.provider.internal.OIDCException: Failed to get access token:null

what’s your take?

On first sight, it looks like your server does not have internet access … e.g. at least DNS resolution does not work





This error has been occured only once and i have provided the host name in apache server.

Access token cannot be accessed is the real issue here

What the error indicate is that the authenticator asked the server for a token and the server answered that it did not want to do that but without any kind of error message.

Maybe you are facing, I would not be surprised that Office 365 require the software accessing the provider to have a special registered id and credentials.

If that’s the issue I unfortunately don’t have much time to work on it these days but maybe you can try with in the meantime which offer some authentication support from what I understand (but never tried it myself).

HI!I have the same error of OpenID Authenticator. I use the OpenID Extension , I got the login page success but after providing right credentials, it displayed same error : org.xwiki.contrib.oidc.provider.internal.OIDCException: Failed to get access token:null
it is maybe because
My oauth server resoponse fine when I use postman to get access token.
I provided the “client_secret”,but the I can’t find where to add this properties in OpenID Extension.Is it because :image.
How I can fix it ?
Thank you very much !

How were you fixed this problem at the end ?:grinning:


This need to be implemented where you found the TODO. Pull request welcome :slight_smile: