Weblate as our new translation platform


#1

The XWiki development team is proud to announce the new translation platform!

We have decided to move to Weblate as it offers many useful features for the translator and is more stable compare to the old l10n platform. Here is a short list of some nice features:

  • Social authentication (GitHub, openSUSE, Ubuntu, Fedora and others if requested)
  • Git commits with your name and email. You can link your contributions to your Github account that way
  • Quality check. For instance you’ll be warned if you put an extra space in a translation
  • Statistics

You can try it now and let us know if you have any issues or just feedback to give.

Thanks,
The XWiki development team


#2

Hi,

I’m not able to connect ;-(:

  • I’ve tried to use my previous weblate login / password created on this platform without success
  • I’ve tried to login wiht Xwiki SSO without success
  • I’ve tried to register but didn’t receive any confirmation email
  • Then I’ve tried to submit a request on page https://l10n.xwiki.org/contact/?t=reg but got an error.

Can you please tell me how to login to improve Xwiki translation. My preference is to use my existing Xwiki account, thanks.


#3

Hello @xrichard,

It seems that you have used Github authentication the first time you logged in and that’s what you should keep on doing. You can also set a password to your account if you want to be able to log in with your credentials.

You haven’t been able to register nor to login through XWiki SSO because your email was already used.
As for the request page, it seems that we haven’t configured it. We will do it as soon as we can.


#4

Thanks for this fast and clear reply.

I agree with you: I first logged in the new platform with GitHub because Xwiki SSO was not available at this time. Is it possible to “switch / associate” my existing account with the “new” Xwiki SSO?

Note: if it’s more simple, I’m OK to delete and recreate my account on the new L10n platform.


#5

As a matter of fact, you can associate other accounts from your profile settings:

Screenshot%20from%202018-06-01%2014-32-53_censored

Let me know if everything works fine for you :slight_smile:


#6

Thanks again for your quick answer :grinning:.

I’ve already tried to add “New association” linked to XWiki when already logged in with my current account but it failed with “L’authentification a été annulée / Authentifcation cancelled”.


#7

I had this error too. I’m not sure where it’s coming from (either from Weblate or from xwiki.org).
You can try to logout from your xwiki.org account and then make the association on Weblate. Your xwiki.org credentials will be asked and it should work after that.
I’m aware this is not a good solution so consider the xwiki.org authentication to be unstable (it can be disabled at any time).


#8

@atallahade I thought we agreed that we should disable the xwiki.org authentication till it’s working fine. It’s still on?


#9

@vmassol I’ve disabled it when we talked about it and re-enabled because it seems to be working again with some other people at the office. I thought the problem might have come from a misconfiguration on Weblate side but now I’m not sure anymore. I’ll disable it for now so users won’t get stuck (sorry @xrichard).


#10

Actually it would be better to have it. My only worry if we disable it is that we’re not going to look into it and fix the problem. Do you have an instance or a way to continue debugging/fixing the problem? :slight_smile:


#11

I think the issue might come from xwiki.org itself. I can’t see what’s happening on this side so I’m kind of stuck.
Edit: It could also be an issue with the token not being refreshed.


#12

It’s possible but many people use it on http://forum.xwiki.org we never get any complain. If you can reproduce the issue on a personal instance (to not mess with l10n.xwiki.org) I can help you debug it.


#13

I can’t reproduce the issue easily. Sometimes it works, sometimes it doesn’t and it’s not completely random so my guess is that a token expire. It could help a lot if you can manually expire one of my token (from xwiki.org) so I can see if the issue happen again or not.


#14

No pb. Just let us know when Xwiki SSO will be officially available for use with WebLate.

Good troubleshooting to all,


#15

@xrichard We’ve hope to fix the issue (but we can’t know for sure until someone report it to be not working), you can try again and let us know if it works for you.


#16

I have added the Xwiki authentication from my Weblate account (called “new association” like shown in your screen shot above) and … tada … everything is working fine! (at least for me)

Many thanks and have a good week-end.


#17

Hi,

I have noticed that’s it not possible to “finish” some components translations because WebLate requires to translate empty string but in the same time reject to save empty string. For instance see: https://l10n.xwiki.org/projects/xwiki-platform/panels-translations/fr/ or https://l10n.xwiki.org/translate/xwiki-platform/main-wikimanager-translations/fr/?type=nottranslated

Can we handle “emtpy strings” in a more gentle way? Note: this problem was already present in the old translation platform.

Regards,


#18

Hi @xrichard,

We will take care of it as soon as we can.

Thanks for telling :slight_smile:


#19

Actually in the old platform there was a checkbox to indicate that you really wanted to translate by an empty string.


#20

If someone was on the platform the last hour, you’ve probably noticed that there was some issues (500 error on save). Don’t worry about it, the issue has been fixed.